Search
lxdream.org :: lxdream/configure.in :: diff
lxdream 0.9.1
released Jun 29
Download Now
filename configure.in
changeset 539:75f3e594d4a7
prev537:d924be49e192
next542:96c5494e02fd
author nkeynes
date Wed Nov 21 11:40:15 2007 +0000 (12 years ago)
permissions -rw-r--r--
last change Add support for the darwin ABI
file annotate diff log raw
1.1 --- a/configure.in Tue Nov 20 10:27:58 2007 +0000
1.2 +++ b/configure.in Wed Nov 21 11:40:15 2007 +0000
1.3 @@ -13,22 +13,39 @@
1.4 AC_CANONICAL_HOST
1.5
1.6 dnl ----------- Check for mandatory dependencies --------------
1.7 +dnl Building on MAC?
1.8 +AC_CHECK_HEADER([Carbon/Carbon.h], [
1.9 + HAVE_CARBON='yes'
1.10 + APPLE_BUILD='yes'
1.11 + LIBS="$LIBS -framework OpenGL -framework AGL -framework Carbon"
1.12 + AC_DEFINE(HAVE_CARBON,[1],[Have Carbon framework])
1.13 + AC_DEFINE(APPLE_BUILD,[1],[Building on an apple platform. Things are different...])
1.14 +])
1.15 +
1.16 dnl Check for libpng (required)
1.17 PKG_CHECK_MODULES(LIBPNG, [libpng] )
1.18
1.19 +dnl Implied by libpng, but check explicitly just in case
1.20 +AC_CHECK_LIB(z, uncompress, [], [
1.21 + echo "Zlib (libz.so) could not be found, but is required."
1.22 + exit 1])
1.23 +
1.24 +if test "$APPLE_BUILD" != 'yes'; then
1.25 AC_CHECK_LIB(GL, glXQueryVersion, [], [
1.26 echo "The OpenGL library (libGL.so) could not be found, but is required."
1.27 exit 1])
1.28 AC_CHECK_HEADER([GL/gl.h], [], [
1.29 echo "The OpenGL header files (eg GL/gl.h) could not be found, but are required."
1.30 exit 1])
1.31 -dnl Implied by libpng, but check explicitly just in case
1.32 -AC_CHECK_LIB(z, uncompress, [], [
1.33 - echo "Zlib (libz.so) could not be found, but is required."
1.34 - exit 1])
1.35 +fi
1.36
1.37 dnl Check for GTK (required for unix systems)
1.38 -PKG_CHECK_MODULES(GTK, gtk+-2.0, [HAVE_GTK='yes'])
1.39 +PKG_CHECK_MODULES(GTK, gtk+-2.0, [
1.40 + HAVE_GTK='yes'
1.41 + AC_DEFINE([HAVE_GTK],1,[Have GTK libraries])
1.42 +])
1.43 +
1.44 +AM_CONDITIONAL(GUI_CARBON, [test "$HAVE_CARBON" = 'yes'])
1.45 AM_CONDITIONAL(GUI_GTK, [test "$HAVE_GTK" = 'yes'])
1.46
1.47 dnl Check for a supported cpu target for translation purposes
.