Search
lxdream.org :: lxdream/RELEASE_NOTES :: diff
lxdream 0.9.1
released Jun 29
Download Now
filename RELEASE_NOTES
changeset 897:163b9ed7899c
prev793:7877d947228d
next1048:0c0947f79563
author nkeynes
date Mon Jun 22 11:32:01 2009 +0000 (10 years ago)
permissions -rw-r--r--
last change Fix silly cut-n-paste error in configure output
file annotate diff log raw
1.1 --- a/RELEASE_NOTES Wed Jul 30 02:26:42 2008 +0000
1.2 +++ b/RELEASE_NOTES Mon Jun 22 11:32:01 2009 +0000
1.3 @@ -1,14 +1,68 @@
1.4 -Release notes for lxdream 0.8.4
1.5 +Release notes for lxdream 0.9 "Shiny"
1.6 ===================================================
1.7
1.8 -Please note that this is still an alpha release - many things are not yet
1.9 -implemented, it has many bugs (especially wrt rendering), and it's
1.10 -not likely to run at 100% speed.
1.11 +Lxdream 0.9 is considerably more stable and accurate than the 0.8 series
1.12 +(thanks more to a huge number of bugfixes than anything else), and the
1.13 +majority of software can be expected to "just work" with minimal problems.
1.14
1.15 -Having said all that, some games are known to run to at least
1.16 -some degree (aka everything we've tried), and most homebrew works
1.17 -perfectly or nearly so - feel free to experiment and let us
1.18 -know how it goes.
1.19 +Nevertheless this should still be considered an alpha release, with many
1.20 +unimplemented features remaining. You're unlikely to see 'perfect' emulation,
1.21 +and we're nowhere near being bug-compatible (in other words, don't expect your
1.22 +code to work on the real hardware just because it runs correctly in lxdream).
1.23 +
1.24 +Changes since 0.8.4
1.25 +-------------------
1.26 +* Improved accuracy + compatibility (many bugfixes)
1.27 +* Shadow volumes
1.28 +* Render-to-texture support
1.29 +* Fogging
1.30 +* Light-gun support
1.31 +
1.32 +Known issues
1.33 +------------
1.34 +The following are known problems in 0.9 that will be fixed in the next major
1.35 +release - in other words, you don't need to report them - we already know :)
1.36 +
1.37 +* Graphic artifacts related to translucent triangle intersections, sorting errors
1.38 + and/of lack of depth precision.
1.39 +
1.40 +* MMU address translation (eg linux, wince, etc) is painfully slow to the
1.41 + point of unusability.
1.42 +
1.43 +* The SH4 emulation is not cycle accurate, and (by default) usually runs
1.44 + slower than the real one. This cause some programs to have timing problems
1.45 + or to break completely. In some cases this can be worked around by
1.46 + adjusting the CPU scaling factor (-m command line option)
1.47 +
1.48 +* Audio quality generally ranges from poor to horrible, interrupted by the
1.49 + occasional bit of fair-to-middling sound.
1.50 +
1.51 +System requirements
1.52 +-------------------
1.53 +Linux:
1.54 + GTK 2.6+
1.55 + Current (2008 or later) ATI or NVidia binary OpenGL drivers
1.56 + - If anyone wants to fix the free drivers, lxdream specifically
1.57 + requires a working implementation of either the EXT_framebuffer_object
1.58 + or GLX_SGIX_pbuffer extensions.
1.59 +
1.60 +OS X:
1.61 + System 10.4 or later
1.62 +
1.63 +GCC, Make, etc.
1.64 +
1.65 +Building
1.66 +--------
1.67 +From the base directory
1.68 +~$ ./configure
1.69 +~$ make
1.70 +~$ make install (optional, GTK only)
1.71 +
1.72 +Enjoy!
1.73 +
1.74 +
1.75 +Older History
1.76 +================
1.77
1.78 Changes since 0.8.3
1.79 -------------------
1.80 @@ -63,32 +117,3 @@
1.81 * Initial IO event system (not widely used yet)
1.82 * Lots of bugfixes throughout the system
1.83
1.84 -Known issues
1.85 -------------
1.86 -The following are known bugs (as opposed to missing features) that will be
1.87 -fixed in the next release, but are too large to be fixed for this version:
1.88 -
1.89 -* Graphic artifacts related to triangle sorting and/of lack of depth
1.90 - precision.
1.91 -
1.92 -System requirements
1.93 --------------------
1.94 -Linux:
1.95 - GTK 2.6+
1.96 - OpenGL drivers with EXT_framebuffer_object or GLX PBuffer support
1.97 - - Currently this means either the ATI or NVidia binary drivers.
1.98 -
1.99 -OS X:
1.100 - System 10.4 or later
1.101 -
1.102 -GCC, Make, etc.
1.103 -
1.104 -Building
1.105 ---------
1.106 -From the base directory
1.107 -~$ ./configure
1.108 -~$ make
1.109 -~$ make install (optional)
1.110 -
1.111 -Enjoy!
1.112 -
.