Search
lxdream.org :: lxdream/debian/postinst.ex :: diff
lxdream 0.9.1
released Jun 29
Download Now
filename debian/postinst.ex
changeset 519:ef9a7f176401
author nkeynes
date Thu Nov 15 12:10:08 2007 +0000 (14 years ago)
permissions -rw-r--r--
last change Add initial debian control files
file annotate diff log raw
1.1 --- /dev/null Thu Jan 01 00:00:00 1970 +0000
1.2 +++ b/debian/postinst.ex Thu Nov 15 12:10:08 2007 +0000
1.3 @@ -0,0 +1,41 @@
1.4 +#!/bin/sh
1.5 +# postinst script for lxdream
1.6 +#
1.7 +# see: dh_installdeb(1)
1.8 +
1.9 +set -e
1.10 +
1.11 +# summary of how this script can be called:
1.12 +# * <postinst> `configure' <most-recently-configured-version>
1.13 +# * <old-postinst> `abort-upgrade' <new version>
1.14 +# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
1.15 +# <new-version>
1.16 +# * <postinst> `abort-remove'
1.17 +# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
1.18 +# <failed-install-package> <version> `removing'
1.19 +# <conflicting-package> <version>
1.20 +# for details, see http://www.debian.org/doc/debian-policy/ or
1.21 +# the debian-policy package
1.22 +
1.23 +
1.24 +case "$1" in
1.25 + configure)
1.26 + ;;
1.27 +
1.28 + abort-upgrade|abort-remove|abort-deconfigure)
1.29 + ;;
1.30 +
1.31 + *)
1.32 + echo "postinst called with unknown argument \`$1'" >&2
1.33 + exit 1
1.34 + ;;
1.35 +esac
1.36 +
1.37 +# dh_installdeb will replace this with shell code automatically
1.38 +# generated by other debhelper scripts.
1.39 +
1.40 +#DEBHELPER#
1.41 +
1.42 +exit 0
1.43 +
1.44 +
.