Search
lxdream.org :: lxdream/debian/prerm.ex :: diff
lxdream 0.9.1
released Jun 29
Download Now
filename debian/prerm.ex
changeset 519:ef9a7f176401
author nkeynes
date Thu Nov 15 12:10:08 2007 +0000 (12 years ago)
permissions -rw-r--r--
last change Add initial debian control files
file annotate diff log raw
1.1 --- /dev/null Thu Jan 01 00:00:00 1970 +0000
1.2 +++ b/debian/prerm.ex Thu Nov 15 12:10:08 2007 +0000
1.3 @@ -0,0 +1,40 @@
1.4 +#!/bin/sh
1.5 +# prerm script for lxdream
1.6 +#
1.7 +# see: dh_installdeb(1)
1.8 +
1.9 +set -e
1.10 +
1.11 +# summary of how this script can be called:
1.12 +# * <prerm> `remove'
1.13 +# * <old-prerm> `upgrade' <new-version>
1.14 +# * <new-prerm> `failed-upgrade' <old-version>
1.15 +# * <conflictor's-prerm> `remove' `in-favour' <package> <new-version>
1.16 +# * <deconfigured's-prerm> `deconfigure' `in-favour'
1.17 +# <package-being-installed> <version> `removing'
1.18 +# <conflicting-package> <version>
1.19 +# for details, see http://www.debian.org/doc/debian-policy/ or
1.20 +# the debian-policy package
1.21 +
1.22 +
1.23 +case "$1" in
1.24 + remove|upgrade|deconfigure)
1.25 + ;;
1.26 +
1.27 + failed-upgrade)
1.28 + ;;
1.29 +
1.30 + *)
1.31 + echo "prerm called with unknown argument \`$1'" >&2
1.32 + exit 1
1.33 + ;;
1.34 +esac
1.35 +
1.36 +# dh_installdeb will replace this with shell code automatically
1.37 +# generated by other debhelper scripts.
1.38 +
1.39 +#DEBHELPER#
1.40 +
1.41 +exit 0
1.42 +
1.43 +
.