Search
lxdream.org :: lxdream/RELEASE_NOTES
lxdream 0.9.1
released Jun 29
Download Now
filename RELEASE_NOTES
changeset 403:1cf393db32f2
prev354:8bf6587e1f9b
next483:e367f778447e
author nkeynes
date Tue Oct 16 12:36:59 2007 +0000 (13 years ago)
permissions -rw-r--r--
last change Downgrade the errors to warnings - they're more whinges than anything fatal
view annotate diff log raw
     1 Release notes for Milestone 3
     2 ===================================================
     4 Please note that this is a development release - many 
     5 things are not yet implemented, it doesn't run at 100% speed, and it's not
     6 particularly user-friendly. If you're looking for something to just
     7 play DC games, you'll probably want to wait for the next version.
     9 Having said all that, some games are known to run to at least 
    10 some degree (aka everything we've tried), and most homebrew works 
    11 perfectly or nearly so - feel free to experiment and let us 
    12 know how it goes.
    14 Changes since Milestone 2
    15 -------------------------
    16 * Implemented the SH4 translation core
    17 * A handful of minor bugfixes
    19 No really, that's it. The good stuff is coming next version, honest
    21 Changes since Milestone 1
    22 -------------------------
    23 * Complete rewrite of nearly all PowerVR2 code - The M1 code was largely a
    24 quick hack to get something running. It's done for real now.
    25 * Initial IO event system (not widely used yet)
    26 * Lots of bugfixes throughout the system
    28 Known issues
    29 ------------
    30 The following are known bugs (as opposed to missing features) that will be
    31 fixed in the next release, but are too large to be fixed for this version:
    33 * Some games experience geometry corruption of varying levels. This is
    34 believed to be caused by an SH4 core bug.
    36 * Polygons that are partially clipped by the view frustum can be distorted
    37 quite badly
    39 System requirements
    40 -------------------
    41 GTK 2.0+
    42 Gnome 2.0+
    43 ESounD 2.36+  (if you want interrupted stuttery sound[0])
    44 OpenGL drivers with EXT_framebuffer_object support (any recent drivers should be
    45 fine)
    46 GCC, Make, etc.
    48 Building
    49 --------
    50 From the base directory
    51 ~$ ./configure
    52 ~$ make
    53 ~$ make install            (optional)
    55 Enjoy!
.