Search
lxdream.org :: lxdream/debian/rules
lxdream 0.9.1
released Jun 29
Download Now
filename debian/rules
changeset 519:ef9a7f176401
next1055:072457c02704
author nkeynes
date Wed Nov 05 10:05:08 2008 +0000 (15 years ago)
permissions -rwxr-xr-x
last change Fix (extremely boneheaded) failure to convert pc to physical address before
storing in the translation cache (in other words, the translation cache was
effectively disabled for MMU code). MMU code is now about 3 times faster...
view annotate diff log raw
     1 #!/usr/bin/make -f
     2 # -*- makefile -*-
     3 # Sample debian/rules that uses debhelper.
     4 # This file was originally written by Joey Hess and Craig Small.
     5 # As a special exception, when this file is copied by dh-make into a
     6 # dh-make output file, you may use that output file without restriction.
     7 # This special exception was added by Craig Small in version 0.37 of dh-make.
     9 # Uncomment this to turn on verbose mode.
    10 #export DH_VERBOSE=1
    13 # These are used for cross-compiling and for saving the configure script
    14 # from having to guess our platform (since we know it already)
    15 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
    16 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
    19 config.status: configure
    20 	dh_testdir
    21 	# Add here commands to configure the package.
    22 ifneq "$(wildcard /usr/share/misc/config.sub)" ""
    23 	cp -f /usr/share/misc/config.sub config.sub
    24 endif
    25 ifneq "$(wildcard /usr/share/misc/config.guess)" ""
    26 	cp -f /usr/share/misc/config.guess config.guess
    27 endif
    28 	./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
    31 build: build-stamp
    33 build-stamp:  config.status
    34 	dh_testdir
    36 	# Add here commands to compile the package.
    37 	$(MAKE)
    38 	#docbook-to-man debian/lxdream.sgml > lxdream.1
    40 	touch $@
    42 clean:
    43 	dh_testdir
    44 	dh_testroot
    45 	rm -f build-stamp 
    47 	# Add here commands to clean up after the build process.
    48 	$(MAKE) distclean
    49 	rm -f config.sub config.guess
    51 	dh_clean 
    53 install: build
    54 	dh_testdir
    55 	dh_testroot
    56 	dh_clean -k 
    57 	dh_installdirs
    59 	# Add here commands to install the package into debian/lxdream.
    60 	$(MAKE) DESTDIR=$(CURDIR)/debian/lxdream install
    63 # Build architecture-independent files here.
    64 binary-indep: build install
    65 # We have nothing to do by default.
    67 # Build architecture-dependent files here.
    68 binary-arch: build install
    69 	dh_testdir
    70 	dh_testroot
    71 	dh_installchangelogs ChangeLog
    72 	dh_installdocs
    73 	dh_installexamples
    74 #	dh_install
    75 #	dh_installmenu
    76 #	dh_installdebconf	
    77 #	dh_installlogrotate
    78 #	dh_installemacsen
    79 #	dh_installpam
    80 #	dh_installmime
    81 #	dh_python
    82 #	dh_installinit
    83 #	dh_installcron
    84 #	dh_installinfo
    85 	dh_installman
    86 	dh_link
    87 	dh_strip
    88 	dh_compress
    89 	dh_fixperms
    90 #	dh_perl
    91 #	dh_makeshlibs
    92 	dh_installdeb
    93 	dh_shlibdeps
    94 	dh_gencontrol
    95 	dh_md5sums
    96 	dh_builddeb
    98 binary: binary-indep binary-arch
    99 .PHONY: build clean binary-indep binary-arch binary install 
.