Search
lxdream.org :: lxdream :: r482:42da008cd8bf
lxdream 0.9.1
released Jun 29
Download Now
changeset482:42da008cd8bf
parent481:3b2d6c5a19ad
child483:e367f778447e
authornkeynes
dateWed Oct 31 12:16:39 2007 +0000 (12 years ago)
Remove gnome dependency - now just depend on GTK 2.0
configure
configure.in
1.1 --- a/configure Wed Oct 31 12:05:23 2007 +0000
1.2 +++ b/configure Wed Oct 31 12:16:39 2007 +0000
1.3 @@ -4947,12 +4947,12 @@
1.4 pkg_cv_PACKAGE_CFLAGS="$PACKAGE_CFLAGS"
1.5 else
1.6 if test -n "$PKG_CONFIG" && \
1.7 - { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \" libgnomeui-2.0 esound libpng \"") >&5
1.8 - ($PKG_CONFIG --exists --print-errors " libgnomeui-2.0 esound libpng ") 2>&5
1.9 + { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \" gtk+-2.0 esound libpng \"") >&5
1.10 + ($PKG_CONFIG --exists --print-errors " gtk+-2.0 esound libpng ") 2>&5
1.11 ac_status=$?
1.12 echo "$as_me:$LINENO: \$? = $ac_status" >&5
1.13 (exit $ac_status); }; then
1.14 - pkg_cv_PACKAGE_CFLAGS=`$PKG_CONFIG --cflags " libgnomeui-2.0 esound libpng " 2>/dev/null`
1.15 + pkg_cv_PACKAGE_CFLAGS=`$PKG_CONFIG --cflags " gtk+-2.0 esound libpng " 2>/dev/null`
1.16 else
1.17 pkg_failed=yes
1.18 fi
1.19 @@ -4965,12 +4965,12 @@
1.20 pkg_cv_PACKAGE_LIBS="$PACKAGE_LIBS"
1.21 else
1.22 if test -n "$PKG_CONFIG" && \
1.23 - { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \" libgnomeui-2.0 esound libpng \"") >&5
1.24 - ($PKG_CONFIG --exists --print-errors " libgnomeui-2.0 esound libpng ") 2>&5
1.25 + { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \" gtk+-2.0 esound libpng \"") >&5
1.26 + ($PKG_CONFIG --exists --print-errors " gtk+-2.0 esound libpng ") 2>&5
1.27 ac_status=$?
1.28 echo "$as_me:$LINENO: \$? = $ac_status" >&5
1.29 (exit $ac_status); }; then
1.30 - pkg_cv_PACKAGE_LIBS=`$PKG_CONFIG --libs " libgnomeui-2.0 esound libpng " 2>/dev/null`
1.31 + pkg_cv_PACKAGE_LIBS=`$PKG_CONFIG --libs " gtk+-2.0 esound libpng " 2>/dev/null`
1.32 else
1.33 pkg_failed=yes
1.34 fi
1.35 @@ -4989,14 +4989,14 @@
1.36 _pkg_short_errors_supported=no
1.37 fi
1.38 if test $_pkg_short_errors_supported = yes; then
1.39 - PACKAGE_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors " libgnomeui-2.0 esound libpng "`
1.40 + PACKAGE_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors " gtk+-2.0 esound libpng "`
1.41 else
1.42 - PACKAGE_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors " libgnomeui-2.0 esound libpng "`
1.43 + PACKAGE_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors " gtk+-2.0 esound libpng "`
1.44 fi
1.45 # Put the nasty error message in config.log where it belongs
1.46 echo "$PACKAGE_PKG_ERRORS" >&5
1.47
1.48 - { { echo "$as_me:$LINENO: error: Package requirements ( libgnomeui-2.0 esound libpng ) were not met:
1.49 + { { echo "$as_me:$LINENO: error: Package requirements ( gtk+-2.0 esound libpng ) were not met:
1.50
1.51 $PACKAGE_PKG_ERRORS
1.52
1.53 @@ -5007,7 +5007,7 @@
1.54 and PACKAGE_LIBS to avoid the need to call pkg-config.
1.55 See the pkg-config man page for more details.
1.56 " >&5
1.57 -echo "$as_me: error: Package requirements ( libgnomeui-2.0 esound libpng ) were not met:
1.58 +echo "$as_me: error: Package requirements ( gtk+-2.0 esound libpng ) were not met:
1.59
1.60 $PACKAGE_PKG_ERRORS
1.61
2.1 --- a/configure.in Wed Oct 31 12:05:23 2007 +0000
2.2 +++ b/configure.in Wed Oct 31 12:16:39 2007 +0000
2.3 @@ -11,7 +11,7 @@
2.4 AC_HEADER_STDC
2.5
2.6 PKG_CHECK_MODULES(PACKAGE,
2.7 - [ libgnomeui-2.0 dnl
2.8 + [ gtk+-2.0 dnl
2.9 esound dnl
2.10 libpng ])
2.11 AC_SUBST(PACKAGE_CFLAGS)
.