Search
lxdream.org :: lxdream :: r804:567a684e1e7a
lxdream 0.9.1
released Jun 29
Download Now
changeset804:567a684e1e7a
parent803:e12b7daf0135
child805:b355f7b3ff2e
authornkeynes
dateThu Aug 07 23:50:52 2008 +0000 (11 years ago)
Add --enable-strict-warn to build with -Wall -Werror
configure
configure.in
1.1 --- a/configure Thu Aug 07 23:36:22 2008 +0000
1.2 +++ b/configure Thu Aug 07 23:50:52 2008 +0000
1.3 @@ -802,6 +802,7 @@
1.4 enable_option_checking
1.5 enable_maintainer_mode
1.6 enable_dependency_tracking
1.7 +enable_strict_warn
1.8 enable_translator
1.9 enable_trace
1.10 enable_watch
1.11 @@ -1467,6 +1468,7 @@
1.12 (and sometimes confusing) to the casual installer
1.13 --disable-dependency-tracking speeds up one-time build
1.14 --enable-dependency-tracking do not reject slow dependency extractors
1.15 + --enable-strict-warn Enable strict compilation warnings
1.16 --disable-translator Disable the SH4 translator (Enable by default)
1.17 --enable-trace Enable generation of IO traces (warning: hurts
1.18 performance)
1.19 @@ -6551,6 +6553,11 @@
1.20
1.21
1.22
1.23 +# Check whether --enable-strict-warn was given.
1.24 +if test "${enable_strict_warn+set}" = set; then
1.25 + enableval=$enable_strict_warn; CFLAGS="$CFLAGS -Werror -Wall -Wno-unused"
1.26 +fi
1.27 +
1.28 # Check whether --enable-translator was given.
1.29 if test "${enable_translator+set}" = set; then
1.30 enableval=$enable_translator; true
1.31 @@ -6796,6 +6803,7 @@
1.32 APPLE_BUILD='yes'
1.33 LIBS="$LIBS -framework AppKit"
1.34 LIBS="$LIBS -Wl,-dylib_file,/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib:/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib -framework OpenGL"
1.35 + CPPFLAGS="$CPPFLAGS -DMAC_OS_X_VERSION_MIN_REQUIRED=MAC_OS_X_VERSION_10_4"
1.36 LDFLAGS="$LDFLAGS -Wl,-headerpad_max_install_names"
1.37
1.38 cat >>confdefs.h <<\_ACEOF
2.1 --- a/configure.in Thu Aug 07 23:36:22 2008 +0000
2.2 +++ b/configure.in Thu Aug 07 23:50:52 2008 +0000
2.3 @@ -19,6 +19,9 @@
2.4
2.5 dnl ---------------- enable/with flags ------------------
2.6
2.7 +AC_ARG_ENABLE( strict-warn,
2.8 + AS_HELP_STRING( [--enable-strict-warn], [Enable strict compilation warnings]),
2.9 + [CFLAGS="$CFLAGS -Werror -Wall -Wno-unused"], [])
2.10 AC_ARG_ENABLE( translator,
2.11 AS_HELP_STRING( [--disable-translator], [Disable the SH4 translator (Enable by default)]),
2.12 [true], [enable_translator=yes] )
2.13 @@ -65,6 +68,7 @@
2.14 APPLE_BUILD='yes'
2.15 LIBS="$LIBS -framework AppKit"
2.16 LIBS="$LIBS -Wl,-dylib_file,/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib:/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib -framework OpenGL"
2.17 + CPPFLAGS="$CPPFLAGS -DMAC_OS_X_VERSION_MIN_REQUIRED=MAC_OS_X_VERSION_10_4"
2.18 LDFLAGS="$LDFLAGS -Wl,-headerpad_max_install_names"
2.19 AC_DEFINE(HAVE_COCOA,[1],[Have Cocoa framework])
2.20 AC_DEFINE(APPLE_BUILD,[1],[Building on an apple platform. Things are different...])
.