Search
lxdream.org :: lxdream :: r793:7877d947228d
lxdream 0.9.1
released Jun 29
Download Now
changeset793:7877d947228d
parent792:1183b763592e
child794:879c5929c7ef
authornkeynes
dateWed Jul 30 02:26:42 2008 +0000 (11 years ago)
Update version number and release notes for 0.8.4
RELEASE_NOTES
configure
configure.in
1.1 --- a/RELEASE_NOTES Wed Jul 30 02:24:06 2008 +0000
1.2 +++ b/RELEASE_NOTES Wed Jul 30 02:26:42 2008 +0000
1.3 @@ -1,4 +1,4 @@
1.4 -Release notes for lxdream 0.8.3
1.5 +Release notes for lxdream 0.8.4
1.6 ===================================================
1.7
1.8 Please note that this is still an alpha release - many things are not yet
1.9 @@ -10,6 +10,15 @@
1.10 perfectly or nearly so - feel free to experiment and let us
1.11 know how it goes.
1.12
1.13 +Changes since 0.8.3
1.14 +-------------------
1.15 +* Fullly native Mac OS X support
1.16 +* Renderer rewrite (fixes perspective correction among other problems)
1.17 +* ALSA and PulseAudio sound drivers
1.18 +* Save states now work on x86-64
1.19 +* New translations: Spanish and Italian
1.20 +* Lots of miscellaneous bug-fixes and improvements
1.21 +
1.22 Changes since 0.8.2
1.23 -------------------
1.24 * MMU Implementation
1.25 @@ -59,16 +68,19 @@
1.26 The following are known bugs (as opposed to missing features) that will be
1.27 fixed in the next release, but are too large to be fixed for this version:
1.28
1.29 -* Polygons that are partially clipped by the view frustum can be distorted
1.30 -quite badly
1.31 -* Limited depth precision causes tearing of view on some scenes.
1.32 +* Graphic artifacts related to triangle sorting and/of lack of depth
1.33 + precision.
1.34
1.35 System requirements
1.36 -------------------
1.37 -GTK 2.6+
1.38 -ESounD 2.36+
1.39 -OpenGL drivers with EXT_framebuffer_object support (any recent drivers should be
1.40 -fine)
1.41 +Linux:
1.42 + GTK 2.6+
1.43 + OpenGL drivers with EXT_framebuffer_object or GLX PBuffer support
1.44 + - Currently this means either the ATI or NVidia binary drivers.
1.45 +
1.46 +OS X:
1.47 + System 10.4 or later
1.48 +
1.49 GCC, Make, etc.
1.50
1.51 Building
2.1 --- a/configure Wed Jul 30 02:24:06 2008 +0000
2.2 +++ b/configure Wed Jul 30 02:26:42 2008 +0000
2.3 @@ -2276,7 +2276,7 @@
2.4
2.5 # Define the identity of the package.
2.6 PACKAGE=lxdream
2.7 - VERSION=0.8.3
2.8 + VERSION=0.8.4
2.9
2.10
2.11 cat >>confdefs.h <<_ACEOF
3.1 --- a/configure.in Wed Jul 30 02:24:06 2008 +0000
3.2 +++ b/configure.in Wed Jul 30 02:26:42 2008 +0000
3.3 @@ -1,7 +1,7 @@
3.4 dnl Process this file with autoconf to produce a configure script.
3.5
3.6 AC_INIT(configure.in)
3.7 -AM_INIT_AUTOMAKE(lxdream, 0.8.3)
3.8 +AM_INIT_AUTOMAKE(lxdream, 0.8.4)
3.9 AM_MAINTAINER_MODE
3.10 AM_CONFIG_HEADER(config.h)
3.11
.