MantisBT - lxdream
View Issue Details
0000070lxdreamAICApublic2009-12-14 11:502019-09-01 06:08
EnigmaticCoder 
nkeynes 
normalcrashalways
closedunable to reproduce 
0.9 
 
0000070: No Sound + Infinite Loop
I'm using the oggvorbis library, and it works on the Dreamcast but doesn't work on lxDream. After a while, it will go into an infinite loop.
No tags attached.
Issue History
2009-12-14 11:50EnigmaticCoderNew Issue
2009-12-14 11:55EnigmaticCoderNote Added: 0000082
2009-12-14 18:18EnigmaticCoderNote Added: 0000083
2010-01-10 17:16nkeynesNote Added: 0000084
2010-01-15 22:21EnigmaticCoderNote Added: 0000087
2019-09-01 06:08nkeynesStatusnew => closed
2019-09-01 06:08nkeynesAssigned To => nkeynes
2019-09-01 06:08nkeynesResolutionopen => unable to reproduce

Notes
(0000082)
EnigmaticCoder   
2009-12-14 11:55   
You know what, I had a timer_spin which was the cause of the infinite loop. Sorry.
(0000083)
EnigmaticCoder   
2009-12-14 18:18   
As a matter of fact, I took that code out and it still crashes.
(0000084)
nkeynes   
2010-01-10 17:16   
Hi Enigmatic,

    If you're seeing a crash, could you please post the full crash-dump report? (If you're not getting a crash-dump report, a backtrace from gdb will suffice).

    For other issues, we really need some kind of test case to be able to reproduce the problem, preferably source + ELF binary (with debugging symbols intact) for non-trivial programs.

Cheers,
Nathan
(0000087)
EnigmaticCoder   
2010-01-15 22:21   
Unfortunately, I don't have a binary of that version anymore. I started testing on the hardware with a BBA at some point in time. Sorry I can't be any more help.