lxdream.org :: Issues
lxdream 0.9.1
released Jun 29
Download Now

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000075lxdreamOtherpublic2013-09-26 15:312019-09-01 05:08
Reporterbogglez 
Assigned Tonkeynes 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000075: Do not include internal glib headers
Descriptionlxdream does not compile with glib >= 2.32

According to https://developer.gnome.org/glib/2.37/glib-compiling.html [^] :

"The recommended way of using GLib has always been to only include the toplevel headers glib.h, glib-object.h, gio.h. Starting with 2.32, GLib enforces this by generating an error when individual headers are directly included."

Patch changes the includes so that glib.h is included instead of internal glib headers.
TagsNo tags attached.
Milestone
Attached Filespatch file icon bogglez_glibincludes.patch [^] (16,644 bytes) 2013-09-26 15:31 [Show Content]

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2013-09-26 15:31 bogglez New Issue
2013-09-26 15:31 bogglez File Added: bogglez_glibincludes.patch
2019-09-01 05:08 nkeynes Status new => closed
2019-09-01 05:08 nkeynes Assigned To => nkeynes
2019-09-01 05:08 nkeynes Resolution open => fixed
.